<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en-us" id="ngin1948" class="ie ie6 lte9 lte8 lte7"> <![endif]-->
<!--[if IE 7]>     <html lang="en-us" id="ngin1948" class="ie ie7 lte9 lte8 lte7"> <![endif]-->
<!--[if IE 8]>     <html lang="en-us" id="ngin1948" class="ie ie8 lte9 lte8"> <![endif]-->
<!--[if IE 9]>     <html lang="en-us" id="ngin1948" class="ie ie9 lte9"> <![endif]-->
<!--[if gt IE 9]>  <html lang="en-us" id="ngin1948"> <![endif]-->
<!--[if !IE]><!--> <html lang="en-us" id="ngin1948"> <!--<![endif]-->
<head>
<!--[if lte IE 9]>
    <meta http-equiv="refresh" content="0; url=/unsupported_browser" />
    <script type="text/javascript">
        window.top.location = '/unsupported_browser';
    </script>
<![endif]-->
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"7b8dc0b815","applicationID":"16731","transactionName":"IQkMERZcXApQQRZeBBUVPQQWR1kFWVYWQwkNEQ==","queueTime":0,"applicationTime":32,"agent":""}</script>
<script type="text/javascript">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</script>
  <meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="5PYVO7rvuo188XAXDyE7ap5kV3xHWwbLf37essro2bqwppGF7HFB1F96fhqfJmJRb2Fp8Z0doQGlbPRYNZJLpQ==" />
<meta name="trace-id" content="9dedbd19-3395-4713-b15a-af3647b130d2" />
  <title>Familiarity surrounds Frozen Four in St. Paul</title>

  <!-- application -->

  <link rel="shortcut icon" href="https://assets.ngin.com/site_files/1948/favicon.ico" />

  


  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1948/page_elements.css?1522272790" />
  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1948/sports.css?1522272790" />
  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/1948/minimal.css?1522272790" id="LayoutThemeCSS" />
  <link rel="stylesheet" media="screen" href="/site_stylesheets_secure/jquery_treeTable.css?1522272790" />
  <link rel="stylesheet" media="screen" href="/stylesheets/sn/shared_components.css?1522272790" />
  <link rel="stylesheet" media="screen" href="//s3.amazonaws.com/sportngin-snap-production/ui_themes/ngin/latest/ngin-bar.css" />


  <!--[if IE 9]>
  <script type="text/javascript" charset="utf-8">var IE = "9";</script>
  <link rel="stylesheet" media="screen" href="/stylesheets/ie9/default_ie9.css?1522272790" />
<![endif]-->

<!--[if IE 8]>
  <script type="text/javascript" charset="utf-8">var IE = "8";</script>
<![endif]-->

<!--[if IE 7]>
  <script type="text/javascript" charset="utf-8">var IE = "7";</script>
<![endif]-->

<!--[if IE 6]>
  <script type="text/javascript" charset="utf-8">var IE = "6";</script>
<![endif]-->

<!--[if lte IE 6]>
  <script type="text/javascript" charset="utf-8">var IE = "6";</script>
<![endif]-->

<!--[if !IE]><!--><script type="text/javascript" charset="utf-8">var IE = null;</script><!-- <![endif]-->


  

  <link rel="stylesheet" media="print" href="/stylesheets/print/website_print.css?1522272790" />

  <script type='text/javascript' src='/javascripts/jquery/jquery-1.7.1.min.js'></script>
<script type='text/javascript'>
  var $j = jQuery.noConflict();
</script>


  
  <meta name="viewport" content="width=1024">

<link rel="stylesheet" href="//assets.ngin.com/site_files/1948/css/1948_styles.css" />
<link rel="stylesheet" href="//assets.ngin.com/site_files/1948/css/1948_xtra_styles.css" />

<script type="text/javascript" src="https://assets.ngin.com/site_files/1948/js/mhj.js"></script>

<script type="text/javascript" src="https://use.typekit.com/omr2dvp.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>


    <style type="text/css">
    
  </style>



  

  <script src="/javascripts/base_packaged.js?1522938380"></script>
<script src="/javascripts/angular_packaged.js?1522938380"></script>

  <script src="/javascripts/dropdown_nav.js?1522938380"></script>

  
  

    <link rel="stylesheet" href="//s3.amazonaws.com/sportngin-snap-production/ui_themes/inline-manual/1/main.css" type="text/css" />

  <script>
      NGIN.inlineManual.setVars({
        in_edit_mode: false,
        org_id: 1924,
        
        site_name: "Minnesota Hockey Journal",
        site_short_name: "Minnesota Hockey Journal",
        site_url: "https://www.minnesotahockeyjournal.com",
        site_id: 1948
      });

  </script>

  <script>!function(){var e=document.createElement("script"),t=document.getElementsByTagName("script")[0];e.async=1,e.src="https://inlinemanual.com/embed/player.cacb2d9a339b3500c03525980ca2a24c.js",e.charset="UTF-8",t.parentNode.insertBefore(e,t)}();</script>


      <link rel="canonical" href="https://www.minnesotahockeyjournal.com/news_article/show/904702" />
      <meta property="og:type" content="article"/>
<meta property="og:title" content="Familiarity surrounds Frozen Four in St. Paul"/>
<meta property="og:description" content="The NCAA Frozen Four ascends upon Xcel Energy Center beginning Thursday and ending with the title game on Saturday.





For 26 players it’s a return to their home state of Minnesota, and for a majority of natives it’s back to a hockey hallowed ground that has already yielded success.





Not only "/>
<meta property="og:url" content="https://www.minnesotahockeyjournal.com/news_article/show/904702-familiarity-surrounds-frozen-four-in-st-paul"/>
<meta property="og:site_name" content="Minnesota Hockey Journal"/>
<meta property="og:image" content="https://cdn4.sportngin.com/attachments/news_article/1011/4851/UMD_celebration_42E4703_large.jpg"/>
<meta name="author" content="Jessi Pierce"/>
<meta property="article:published_time" content="2018-04-05T09:00:00-05:00"/>
<meta property="article:section" content="Sports"/>
    <meta property="article:tag" content="Ice Hockey"/>



    


  
  
    <style>.async-hide { opacity: 0 !important} </style>
  <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-821370-1', 'auto', {'allowLinker': true});
    ga('set', 'dimension2', 'ice-hockey');
    ga('set', 'dimension3', '1948');
    ga('set', 'dimension4', 'MN');
    ga('require', 'linker');
    ga('linker:autoLink', ['www.minnesotahockeyjournal.com', 'mnhockeyjournal.sportngin.com']);
    ga('send', 'pageview');

          ga('create', 'UA-12591425-1', 'auto', {'name': 'siteTracker', 'allowLinker': true});
          ga('siteTracker.require', 'linker');
          ga('siteTracker.linker:autoLink', ['www.minnesotahockeyjournal.com', 'mnhockeyjournal.sportngin.com']);
          ga('siteTracker.send', 'pageview');
    </script>
    <!-- Quantcast Tag, part 1 -->
    <script type="text/javascript">
      var _qevents = _qevents || [];

      (function() {
        var elem = document.createElement('script');

        elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName('script')[0];
        scpt.parentNode.insertBefore(elem, scpt);
      })();
    </script>


  

  <script>
  var recaptchaSiteKey = "6LePJx8TAAAAACXrjU21ZdxvkXD_rh3yzhSeoJ0a"
</script>
<script src="/javascripts/grecaptcha.js?1522938380"></script>
<script src="https://www.google.com/recaptcha/api.js?onload=recaptchaOnloadCallback&render=explicit" async defer></script>


  <script>
//<![CDATA[
  window.nginSite = {"domain_name":"minnesotahockeyjournal.com","subdomain":"www","name":"Minnesota Hockey Journal","short_name":"Minnesota Hockey Journal","secure_subdomain":"mnhockeyjournal"}

//]]>
</script>

    </head>

<body class="minimal noUserBar user_mode newsPage">


    <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  // js.src = "//connect.facebook.net/en_US/all/debug.js#xfbml=1&version=v2.3"; // use if debugging
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


  <a href="#yieldContent" style="color:#FFF;position:absolute;height:1px;width:1px;left:-9999px;">skip navigation</a>

  

  <div id="top"></div>
  
  
  


  <div id="siteContainer2" class="siteContainer two_panel">
    
    
    <div id="siteHeader" class="bannerGraphic">
    <div class="secondary">
  <div class="social">
    <a title="facebook" href="http://www.facebook.com/MinnesotaHockeyJournal">Facebook</a>
    <a title="twitter" href="http://twitter.com/mnhockeyjournal">Twitter</a>
  </div>
  <span>The official publication of</span>
  <a title="usahockey" href="http://www.usahockey.com/">USA Hockey</a>
</div>
<a class="homeLink" title="Home" href="/">Home</a>      <h1><a title="Minnesota Hockey Journal Homepage" href="https://www.minnesotahockeyjournal.com">Minnesota Hockey Journal</a></h1>
  
  
  
</div>

    
<div id="topNav">
</div>

<script type="text/javascript" charset="utf-8">


  ;(function($) {

    function topNavSelect() {
      $(function() {
        $('#nav_id-page_node_353600').addClass('selected').closest('td').addClass('selected');
        $('#topNav').trigger('topnav.loaded');
      });
    }

      var navOpts = {
        url: '/navigation/site_dropdown_nav?id=353600',
        context: document.body,
        cache: false,
        async: true,
        timeout: 30000,
        success: function(data) {
          $('#topNav').html(data);
        }
      }
      $.ajax(navOpts).done(topNavSelect);


  })(jQuery);

</script>


    
    <div id="pageContentContainer">
      
        <div id="panelOne">
          <div class="subNavContainer">
  <div class="subNav">
    <h4>Current Section</h4>
      <ul class="parents" id="parent_nodes">
        <li id="page_node_353600" class="enabled selected"><a href="/page/show/353600-issue-archive" title="click to go to 'Issue Archive'">Issue Archive</a></li>
      </ul>

      <ul class="children" id="child_nodes">
          <li id="page_node_399657" class="enabled"><a href="/page/show/399657-issue-archive" title="click to go to 'Issue Archive'">Issue Archive</a></li>
          <li id="page_node_3443739" class="enabled"><a href="/page/show/3443739-digital-editions" title="click to go to 'Digital Editions'">Digital Editions</a></li>
      </ul>
  </div>

</div>


          
<div id="leftHandGraphics">
</div>



        </div><!-- closing panelOne -->
      <div id="panelTwo">
        <div id="displayBodyContent">
          <div id="yieldContent">
                  <h2 id="displayBodyHeader" class=""><span></span></h2>


            <div id="errorNotice">
  
  
  
  
  
</div>



            <div class='yieldAdminContent'></div>
            <div class='yieldPageContent'>
            <div class="layoutContainer oneColumn newsItemColumn">
  <div class="newsItemElement pageElement">
      <img class="newsPreviewThumb" alt="" width="75" src="https://cdn2.sportngin.com/attachments/news_article/1011/4851/UMD_celebration_42E4703_thumb.jpg" />
    <h2>Familiarity surrounds Frozen Four in St. Paul</h2>
    <div class="newsDate">04/05/2018, 9:00am CDT</div>
    <div class="newsAuthor">By Jessi Pierce</div>
  </div>
    <div class="pageElement textBlockElement">
      
    </div>
</div>
<div class="newsContentNode">      <div class="layoutContainer oneColumn ">
    
          <div class="column1 column pe100">
                <div id="pageEl_403506852" class="pageEl"  >
  
        <div class="pageElement heroPhotoElement">

      <img src="https://cdn3.sportngin.com/attachments/photo/1011/4852/UMD_celebration_42E4703_large.jpg" alt="" />
      </div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_403506977" class="pageEl"  >
  
      <div class="pageElement textBlockElement clearfix">
  


    <div class="text clearfix">
      <p><span style="font-size:14px">The NCAA Frozen Four ascends upon Xcel Energy Center beginning Thursday and ending with the title game on Saturday.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">For 26 players it&rsquo;s a return to their home state of Minnesota, and for a majority of natives it&rsquo;s back to a hockey hallowed ground that has already yielded success.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">Not only did the lone team representing Minnesota, Minnesota Duluth, claim their first-ever title in program history at Xcel Energy Center in 2011&mdash;the last time St. Paul hosted the Frozen Four&mdash;but a number of players have either participated or won the coveted Minnesota State High School boy&rsquo;s hockey tournament in the same building.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">Minnesota Duluth coach Scott Sandelin led the Bulldogs to the championship banner seven years ago and was witness to his son, Ryan, winning back-to-back state titles with Hermantown High School in 2016 and 2017.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">&ldquo;I mean the national championship for me [was special],&rdquo; Sandelin said, identifying that feat as his top moment at Xcel Energy Center. &ldquo;When you do something for the first time in program history, it&#39;s special.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">&ldquo;I would probably say real close to that is watching my [son]. I actually didn&#39;t see the second state championship, I saw the first state championship, so I&#39;ll put that right underneath (winning our national championship). Not to be selfish, but it was pretty special for our program to do that here.&rdquo;</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">Bulldog defenseman Dylan Samberg captained that Hermantown team.</span></p>

<p>&nbsp;</p>

    </div>
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_403507172" class="pageEl"  >
  
      <div class="pageElement textBlockElement clearfix">
  


    <div class="text clearfix">
      <blockquote>
<p><span style="color:#000080"><span style="font-family:calibri,sans-serif"><span style="font-size:12.0pt">&ldquo;Any Frozen Four is extremely special, but knowing it&#39;s in Saint Paul, that kind of meant a little more to me.&rdquo; </span></span></span></p>

<p><span style="color:#000080"><span style="font-family:calibri,sans-serif"><span style="font-size:12.0pt">Notre Dame defenseman Jordan Gross&nbsp;(Maple Grove)</span></span></span></p>
</blockquote>

    </div>
</div>

  <span class="clearAll"></span>
</div>


                <div id="pageEl_403507010" class="pageEl"  >
  
      <div class="pageElement textBlockElement clearfix">
  


    <div class="text clearfix">
      <p><span style="font-size:14px">Notre Dame senior defenseman Jordan Gross, who pushed the Fighting Irish past the first round with an overtime goal against Providence College in the NCAA East Regional semifinals, was a part of a Maple Grove High School squad that made its first-ever state tournament appearance in 2012. Fate wasn&rsquo;t in store for Gross and Maple Grove, who were knocked out in the first round.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">&ldquo;Any Frozen Four is extremely special, but knowing it&#39;s in Saint Paul, that kind of meant a little more to me,&rdquo; Gross said.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">Gross&rsquo; Notre Dame teammate Dylan Malmquist was on the winning end of state with the Edina Hornets, capturing back-to-back titles in Class AA in 2013 and 2014 along with Ohio State&rsquo;s Miguel Fidler. Bulldogs forward Joey Anderson made a state tournament appearance with the Hill Murray Pioneers in 2013. The list goes on.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">And while some are getting re-acquainted with the Minnesota Wild&rsquo;s home facility, three Wild prospects will be familiarizing themselves with what could be their potential NHL home rink. Avery Peterson (Minnesota Duluth), Nick Swaney (Minnesota Duluth) and Nicholas Boka (Michigan) all have their rights owned by the Wild. Minnesota leads all 31 NHL teams with three prospects competing for the championship banner this weekend.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">Ultimately, players and coaches from top to bottom seem to be happy to be hosted by Minnesota.</span></p>

<p>&nbsp;</p>

<p><span style="font-size:14px">&ldquo;I wanna give a shoutout to St. Paul and the Xcel Energy Center,&rdquo; Michigan coach Mel Pearson said. &ldquo;When&hellip;you&#39;re looking for different places to put (the tournament), this is one of the cities that comes to mind right away. You could almost do it every year here. They do a fantastic job here.&rdquo;</span></p>

    </div>
</div>

  <span class="clearAll"></span>
</div>


        </div>
    <span class="clearAll"></span>
  </div>




</div>

<p class="newsTags pageElement">Tag(s):
        <a href="https://www.minnesotahockeyjournal.com/page/show/353193-minnesota-hockey-journal">Home</a>&nbsp;

</p>

<div class="bottomOptions">
  <ul class="pageOptions">
    <li><a href="javascript: history.go(-1)" class="goBackLink icon">Back to Previous Page</a></li>
    <li><a class="printLink icon" href="javascript:window.print()">Print This Page</a></li>
    <li><!-- AddThis Button BEGIN -->
<a href="//www.addthis.com/bookmark.php" onclick="addthis_url   = location.href; addthis_title = document.title; return addthis_click(this);" target="_blank"><img src="//s9.addthis.com/button0-share.gif" width="83" height="16" border="0" alt="Bookmark and Share" style="vertical-align: bottom;" /></a> <script type="text/javascript">var addthis_pub = 'tstmediallc';</script><script type="text/javascript" src="//s9.addthis.com/js/widget.php?v=10"></script>  
<!-- AddThis Button END -->
</li>
  </ul>
</div>

<script type="text/javascript">
  $j(document).ready(function() {
    $j.get("/news_article/visit/904702")
  })
</script>


            </div>


          </div>
        </div>
        <div class="clearAll"></div>
      </div><!-- closing panelTwo -->

      
      
      <div class="clearAll"></div>
      
    </div><!--  closing pageContentContainer3  -->
  <div class="footerPush"></div>
  </div><!--  closing siteContainer3  -->

  <div id="siteFooter">
  
    
    <ul class="nav"></ul>
<div class="social">
  <a title="facebook" href="http://www.facebook.com/MinnesotaHockeyJournal">Facebook</a>
  <a title="twitter" href="http://twitter.com/mnhockeyjournal">Twitter</a>
</div>
<ul class="privacy"></ul>
    <ul>
      <li>&copy;2018 Minnesota Hockey Journal / <a href="https://sportsengine.com/?lead_source=SportsEngine%20Platform&utm_source=footerlogo" >SportsEngine</a>. All Rights Reserved.</li>
      <li><a class="legalLink" href="/legal/terms_of_use">Terms of Use</a></li>
        <li><a class="legalLink" href="https://www.sportsengine.com/legal/privacy_policy">Privacy Policy</a></li>
      <li><a class="legalLink" href="/help">Contact a Site Admin</a></li>
      <li><a class="legalLink" id="loginLink" href="https://login.sportngin.com">Login</a></li>
      <li id="poweredByNGIN"><a href="https://www.sportsengine.com/?lead_source=SportsEngine%20Platform&utm_source=footerlogo" onclick="javascript:window.location=('https://www.sportsengine.com/?lead_source=SportsEngine%20Platform&utm_source=footerlogo'); return false;"><img src="/logo_images/white_logo.png" alt="Powered by SportsEngine" title="Click here to learn how SportsEngine can empower your organization!" /></a></li>
    </ul>
</div>

  
    
    

  
  
  
  <!-- Quantcast Tag, part 2 -->
<script type="text/javascript">
  _qevents.push({
    qacct: "p-56Ph9bjA0FOcE",
    labels: "Sport.ice-hockey, State.MN, Site.1948, Ads.No"
  });
</script>
<noscript>
  <div style="display:none;">
    <img width="1" height="1" border="0" alt="Quantcast" src="https://pixel.quantserve.com/pixel/p-56Ph9bjA0FOcE.gif" />
  </div>
</noscript>
<!-- End Quantcast tag -->

  
</body>
</html>
